R1的配置:
sh run
Building configuration...
Current configuration : 1125 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
enable password cisco
!
ip subnet-zero
!
!
!
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
!
interface FastEthernet1/0.1
encapsulation dot1Q 56
ip address 10.226.56.1 255.255.254.0
!
interface FastEthernet1/0.2
encapsulation dot1Q 58
ip address 10.226.58.1 255.255.255.0
!
interface FastEthernet1/0.3
encapsulation dot1Q 1 native
ip address 10.3.2.254 255.255.255.0
!
interface FastEthernet2/0
no ip address
duplex auto
speed auto
!
interface FastEthernet2/0.1
encapsulation dot1Q 59
ip address 10.226.59.1 255.255.255.128
!
interface FastEthernet2/0.2
encapsulation dot1Q 60
ip address 10.226.59.129 255.255.255.128
!
interface FastEthernet2/0.3
encapsulation dot1Q 1 native
ip address 10.3.3.2 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.226.59.254
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
end
Router1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 10.226.59.254 to network 0.0.0.0
10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
C 10.3.3.0/24 is directly connected, FastEthernet2/0.3
C 10.3.2.0/24 is directly connected, FastEthernet1/0.3
C 10.226.59.128/25 is directly connected, FastEthernet2/0.2
C 10.226.56.0/23 is directly connected, FastEthernet1/0.1
C 10.226.58.0/24 is directly connected, FastEthernet1/0.2
C 10.226.59.0/25 is directly connected, FastEthernet2/0.1
S* 0.0.0.0/0 [1/0] via 10.226.59.254
R2:
Router2>
Router2>ena
Password:
Router2#sh run
Building configuration...
Current configuration : 736 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
username cisco password 0 cisco
no aaa new-model
ip subnet-zero
!
!
!
no ftp-server write-enable
!
!
!
interface Loopback0
ip address 10.3.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.226.59.254 255.255.255.128
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.30.4.7 255.255.255.0
duplex auto
speed auto
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.30.4.1
ip route 10.226.56.0 255.255.252.0 10.226.59.129
ip http server
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
!
end
Router2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is 172.30.4.1 to network 0.0.0.0
172.30.0.0/24 is subnetted, 1 subnets
C 172.30.4.0 is directly connected, FastEthernet0/1
10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C 10.3.1.0/24 is directly connected, Loopback0
C 10.226.59.128/25 is directly connected, FastEthernet0/0
S 10.226.56.0/22 [1/0] via 10.226.59.129
S* 0.0.0.0/0 [1/0] via 172.30.4.1
Router2#
Router2#
Router2#exit
SW1
SW1>ena
Password:
SW1#
SW1#
SW1#
SW1#
SW1#sh run
Building configuration...
Current configuration : 2693 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW1
!
enable password cisco
!
ip subnet-zero
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/2
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/3
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/4
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/5
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/6
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/7
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/8
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/9
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/10
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/11
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/12
switchport access vlan 56
switchport mode access
no ip address
!
interface FastEthernet0/13
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/14
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/15
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/16
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/17
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/18
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/19
switchport access vlan 58
switchport mode access
no ip address
interface FastEthernet0/20
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/21
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/22
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/23
switchport access vlan 58
switchport mode access
no ip address
!
interface FastEthernet0/24
switchport mode trunk
no ip address
interface Vlan1
ip address 10.3.2.1 255.255.255.0
no ip route-cache
!
ip http server
!
!
line con 0
line vty 0 4
password cisco
login
line vty 5 15
login
!
end
SW1#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
10 VLAN_A active
11 VLAN11 active
12 VLAN12 active
56 VLAN56-57 active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
58 VLAN-58 active Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
11 enet 100011 1500 - - - - - 0 0
12 enet 100012 1500 - - - - - 0 0
56 enet 100056 1500 - - - - - 0 0
58 enet 100058 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
SW2:
SW2#sh run
Building configuration...
Current configuration : 2388 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW2
!
enable password cisco
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface FastEthernet0/1
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/2
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/3
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/4
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/5
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/6
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/7
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/8
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/9
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/10
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/11
switchport access vlan 59
switchport mode access
!
interface FastEthernet0/12
switchport access vlan 59
switchport mode access
switchport port-security mac-address 00d0.0949.4343
!
interface FastEthernet0/13
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/14
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/15
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/16
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/17
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/18
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/19
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/20
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/21
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/22
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/23
switchport access vlan 60
switchport mode access
!
interface FastEthernet0/24
switchport mode trunk
!
interface Vlan1
ip address 10.3.3.1 255.255.255.0
no ip route-cache
!
ip http server
!
!
line con 0
line vty 0 4
password cisco
login
line vty 5 15
login
!
end
SW2#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
10 VLAN_A active
11 VLAN11 active
12 VLAN12 active
59 VLAN59_1 active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
60 VLAN59-2 active Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
11 enet 100011 1500 - - - - - 0 0
12 enet 100012 1500 - - - - - 0 0
59 enet 100059 1500 - - - - - 0 0
60 enet 100060 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
局端路由:
IP ROUTE 10.226.56.0 255.255.252.0 172.30.254.254